diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 11 |
1 files changed, 10 insertions, 1 deletions
@@ -20,8 +20,16 @@ materializedDefsToScope materializeOpamProject'; package = "wormhole"; + devPackagesQuery = { + ocaml-lsp-server = "*"; + ocamlformat = "*"; + # 1.9.6 fails to build + ocamlfind = "1.9.5"; + utop = "*"; + }; query = { ocaml-base-compiler = "*"; + ocamlformat = "*"; }; overlay = final: prev: { "${package}" = prev.${package}.overrideAttrs (_: { @@ -33,6 +41,7 @@ ]; }); }; + devBuildInputs = [ pkgs.ocamlPackages.ocamlformat ]; resolved-scope = let scope = buildOpamProject { } package ./. query; in scope.overrideScope' overlay; @@ -51,7 +60,7 @@ defaultPackage = packages.materialized.${package}; devShells.default = pkgs.mkShell { inputsFrom = [ defaultPackage ]; - buildInputs = []; + buildInputs = devBuildInputs; }; } ); |