diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 26 |
1 files changed, 8 insertions, 18 deletions
@@ -33,9 +33,14 @@ ${package} = prev.${package}.overrideAttrs (_: { # Prevent the ocaml dependencies from leaking into dependent environments doNixSupport = false; - buildInputs = - [ pkgs."gmp" pkgs."libev" pkgs."openssl" pkgs."libargon2" ]; - DUNE_PROFILE = "release"; + buildInputs = [ + pkgs.glibc.static + pkgs.zlib.static + pkgs.binutils-unwrapped + pkgs.ocaml + pkgs.musl + pkgs.gcc + ]; }); }; scope' = scope.overrideScope' overlay; @@ -49,21 +54,6 @@ packages.default = main; - - defaultPackage = pkgs.stdenv.mkDerivation { - name = "stitch"; - src = ./.; - buildInputs = devPackages; - buildPhase = '' - dune build --profile release - ''; - - installPhase = '' - echo "building to $out" - cp _build/install/default/bin/stitch/ $out - ''; - }; - apps.stitch.default = { type = "app"; program = "${main}/bin/stitch"; |