summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..82dc5b1
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+ description = "Run Ann Server as a systemd service";
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs?ref=nixpkgs-unstable";
+ inputs.ann.url = "git+https://git.sr.ht/~marcc/ann_bloop";
+
+
+ outputs = {self,nixpkgs, ann, ...}@inputs: {
+ nixosConfigurations.nix = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs;};
+ system = "x86_64-linux";
+ modules = [
+ ./configuration.nix
+ ];
+ };
+ };
+}