summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/configuration.nix b/configuration.nix
index 0ddc4c8..95668c8 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,6 +1,7 @@
{ pkgs, inputs, ... }:
let
cgitCss = pkgs.writeText "cgit.css" (builtins.readFile ./cgit.css);
+ blobs = pkgs.readDir "blobs"
in {
imports = [
./hardware-configuration.nix
@@ -12,7 +13,8 @@ in {
networking.nat.externalInterface = "eth0";
systemd.tmpfiles.rules = [
- "d /mnt/ 700 root root -"
+ "d /mnt/ 700 root root -";
+ "d /www/data/releases/ 700 nginx nginx"
];
containers.ann = {
@@ -144,6 +146,14 @@ in {
};
+ virtualHosts."blobs.mccd.space" = {
+ forceSSL = true;
+ enableACME = true;
+ locations."/" = {
+ root = "${blobs}";
+ };
+ };
+
virtualHosts."rss.mccd.space" = {
forceSSL = true;
enableACME = true;