summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/configuration.nix b/configuration.nix
index bb6f59a..a6f6f26 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -24,6 +24,13 @@
baseUrl = "https://rss.mccd.space";
};
+ services.cron = {
+ enable = true;
+ systemCronJobs = [
+ "10 * * * * www-data php -f ${pkgs.freshrss}/app/actualize_script.php > /tmp/FreshRSS.log 2>&1"
+ ];
+ };
+
services.postgresql = {
enable = true;
ensureDatabases = [ "ann" ];