summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configuration.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/configuration.nix b/configuration.nix
index fe96a43..39e1874 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -11,6 +11,10 @@ in {
networking.nat.internalInterfaces = [ "ve-*" ];
networking.nat.externalInterface = "eth0";
+ systemd.tmpfiles.rules = [
+ "d /mnt/ 700 root root -"
+ ];
+
containers.ann = {
autoStart = true;
hostAddress = "192.168.100.2";
@@ -24,10 +28,17 @@ in {
hostPath = "/mnt/ann/";
isReadOnly = false;
};
+ "/srv/ann-queue" = {
+ hostPath = "/mnt/ann-queue/";
+ isReadOnly = false;
+ };
};
config = { config, pkgs, ... }: {
- systemd.tmpfiles.rules = [ "d /srv/ann 700 ann ann -" ];
+ systemd.tmpfiles.rules = [
+ "d /srv/ann 700 ann ann -"
+ "d /srv/ann-queue 700 guest guest -"
+ ];
users.users.ann = {
isSystemUser = true;
home = "/srv/ann";
@@ -35,6 +46,12 @@ in {
extraGroups = [ "wheel" ];
};
users.groups.ann = {};
+
+ services.rabbitmq = {
+ enable = "true";
+ listenAdress = "127.0.0.1";
+ };
+
systemd.services.ann = {