summaryrefslogtreecommitdiff
path: root/networking.nix
diff options
context:
space:
mode:
authorSystem administrator <root@nix.webgit.mccd.space>2024-01-20 21:18:57 +0000
committerSystem administrator <root@nix.webgit.mccd.space>2024-01-20 21:18:57 +0000
commitc3a5ade1e80934f13b4760ebaddfbe7c0ca356e5 (patch)
tree2e098a711f25b8b7f653c788bd002e0e80ce1a3b /networking.nix
downloadnixos-c3a5ade1e80934f13b4760ebaddfbe7c0ca356e5.tar.gz
nixos-c3a5ade1e80934f13b4760ebaddfbe7c0ca356e5.tar.bz2
nixos-c3a5ade1e80934f13b4760ebaddfbe7c0ca356e5.zip
Add initial nix config
Diffstat (limited to '')
-rw-r--r--networking.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/networking.nix b/networking.nix
new file mode 100644
index 0000000..2f1b2be
--- /dev/null
+++ b/networking.nix
@@ -0,0 +1,35 @@
+{ lib, ... }: {
+ # This file was populated at runtime with the networking
+ # details gathered from the active system.
+ networking = {
+ nameservers = [ "2a01:4ff:ff00::add:2"
+ "2a01:4ff:ff00::add:1"
+ "185.12.64.1"
+ ];
+ defaultGateway = "172.31.1.1";
+ defaultGateway6 = {
+ address = "fe80::1";
+ interface = "eth0";
+ };
+ dhcpcd.enable = false;
+ usePredictableInterfaceNames = lib.mkForce false;
+ interfaces = {
+ eth0 = {
+ ipv4.addresses = [
+ { address="128.140.49.64"; prefixLength=32; }
+ ];
+ ipv6.addresses = [
+ { address="2a01:4f8:c17:ddd1::1"; prefixLength=64; }
+{ address="fe80::9400:2ff:feeb:f56c"; prefixLength=64; }
+ ];
+ ipv4.routes = [ { address = "172.31.1.1"; prefixLength = 32; } ];
+ ipv6.routes = [ { address = "fe80::1"; prefixLength = 128; } ];
+ };
+
+ };
+ };
+ services.udev.extraRules = ''
+ ATTR{address}=="96:00:02:eb:f5:6c", NAME="eth0"
+
+ '';
+}